ĐỀ CƯƠNG TIN 8
I. TRẮC NGHIỆM
Câu 1. Cấu trúc điều khiển nào giúp thực hiện một câu lệnh nếu điều kiện đúng?
	 A. Câu lệnh biểu thức
	 B. Câu lệnh khai báo

	 C. Vòng lặp
	 D. Câu lệnh điều kiện IF


Câu 2. Gỡ lỗi trong lập trình là gì?
   A. Tìm và sửa lỗi trong chương trình
   B. Kiểm tra tốc độ thực thi của chương trình
   C. Thêm mã nguồn vào chương trình
   D. Tạo chương trình mới
Câu 3. Hiệu ứng hoạt hình cho văn bản hoặc hình ảnh trên trang chiếu được thiết lập trong thẻ nào?
	 A. Slide Show
	 B. Animation
	 C. View
	 D. Transition


Câu 4. Lỗi trong chương trình có thể là:
	 A. Không có lỗi trong chương trình
	 B. Chỉ có lỗi logic

	 C. Chỉ có lỗi cú pháp
	 D. Lỗi cú pháp và lỗi logic


Câu 5. Chức năng "Link to Previous" trong đầu trang/chân trang có tác dụng gì?
   A. Giúp đầu trang/chân trang giống nhau giữa các phần
   B. Sao chép nội dung văn bản chính vào đầu trang
   C. Tạo liên kết giữa các đoạn văn
   D. Chèn hình ảnh vào đầu trang
Câu 6. Bản mẫu (template) trong PowerPoint là gì?
   A. Một tệp văn bản mới
   B. Một bố cục trình chiếu có sẵn định dạng và thiết kế
   C. Một hình ảnh nền
   D. Một hiệu ứng hoạt hình
Câu 7. Chức năng nào giúp áp dụng hiệu ứng chuyển tiếp giữa các trang chiếu?
	 A. Transition
	 B. Animation
	 C. Design
	 D. Insert


Câu 8. Sử dụng bản mẫu giúp người trình bày:
   A. Giảm số lượng trang chiếu
   B. Làm văn bản ngắn lại
   C. Trình bày nội dung ngắn gọn, khoa học hơn
   D. Chèn được nhiều hình hơn
Câu 9. Một bản mẫu trong PowerPoint thường bao gồm:
	 A. Hình nền, kiểu chữ và bố cục
	 B. Hình ảnh động

	 C. Hiệu ứng và âm thanh
	 D. Chỉ có tiêu đề trang chiếu


Câu 10. Khi sử dụng bản mẫu có sẵn, em vẫn có thể:
   A. Chỉ xem, không thể chỉnh sửa
   B. Thêm biểu đồ nhưng không chỉnh sửa được chữ
   C. Thêm, xóa và chỉnh sửa nội dung theo ý muốn
   D. Chỉ thay đổi hiệu ứng
Câu 11. Em áp dụng hiệu ứng "Fade" cho hình ảnh trong trang chiếu để làm gì?
   A. Làm cho hình ảnh xuất hiện dần một cách mượt mà
   B. Làm cho hình ảnh chuyển động liên tục
   C. Làm cho hình ảnh bị ẩn
   D. Làm hình ảnh bị mờ
Câu 12. Khi gặp lỗi cú pháp trong chương trình, lập trình viên cần:
   A. Chạy lại chương trình nhiều lần
   B. Kiểm tra lại cấu trúc của câu lệnh
   C. Đặt thêm các câu lệnh để kiểm tra dữ liệu
   D. Thay đổi hoàn toàn chương trình
Câu 13. Chương trình máy tính là gì?
   A. Một đoạn phim hoạt hình
   B. Một trang chiếu trình bày bằng PowerPoint
   C. Một tập hợp các câu lệnh viết bằng ngôn ngữ lập trình để thực hiện thuật toán
   D. Một bài văn viết trên Word
Câu 14. Khi nào ta nên sử dụng hằng trong lập trình?
   A. Khi cần lưu trữ dữ liệu tạm thời
   B. Khi muốn kết hợp nhiều phép toán phức tạp
   C. Khi giá trị đó không thay đổi trong suốt chương trình và cần sử dụng nhiều lần
   D. Khi muốn giá trị đó thay đổi trong quá trình thực thi chương trình
Câu 15. Cấu trúc điều khiển trong lập trình dùng để làm gì?
   A. Để hiển thị thông tin ra màn hình
   B. Để lưu trữ dữ liệu
   C. Để điều khiển dòng chảy thực thi của chương trình
   D. Để khai báo các biến trong chương trình
Câu 16. Để chèn biểu đồ vào trang chiếu, em sử dụng lệnh nào?
	 A. View → Ruler
	 B. Insert → Picture
	 C. Home → Table
	 D. Insert → Chart


Câu 17. Khi định dạng nâng cao cho trang chiếu, việc sử dụng quá nhiều hiệu ứng có thể gây ra điều gì?
   A. Gây rối mắt và khó theo dõi nội dung
   B. Làm trang chiếu sinh động hơn
   C. Làm bài thuyết trình nổi bật hơn
   D. Làm người xem tập trung hơn
Câu 18. Vì sao nên sử dụng đầu trang hoặc chân trang trong văn bản dài?
   A. Làm cho văn bản ngắn lại
   B. Để văn bản có nhiều màu sắc hơn
   C. Giúp trình bày văn bản sinh động hơn
   D. Giúp người đọc dễ theo dõi thông tin như tiêu đề, số trang
Câu 19. Dữ liệu dạng văn bản bao gồm:
	 A. Hình ảnh, biểu đồ và video
	 B. Các mã lệnh lập trình

	 C. Chữ cái, chữ số và ký hiệu
	 D. Các đoạn nhạc


Câu 20. Tại sao cần chuyển thuật toán thành chương trình máy tính?
   A. Vì thuật toán chỉ dùng để học lý thuyết
   B. Vì chương trình dễ in ra giấy hơn
   C. Vì chương trình có nhiều màu sắc hơn
   D. Vì máy tính chỉ hiểu và thực hiện được chương trình được viết bằng ngôn ngữ lập trình
Câu 21. Bản mẫu trong PowerPoint thường được lưu với phần mở rộng nào?
	 A. .xlsx
	 B. .potx
	 C. .pptx
	 D. .docx


Câu 22. Để thêm chân trang, em chọn lệnh nào trong tab Insert?
	 A. Insert → Header
	 B. Insert → Footer
	 C. Insert → Text Box
	 D. Insert → Symbol


Câu 23. Dữ liệu trong máy tính được biểu diễn dưới dạng nào?
	 A. Hình ảnh và âm thanh
	 B. Các chữ cái từ A đến Z

	 C. Dãy các số 0 và 1
	 D. Văn bản thông thường


Câu 24. Nếu muốn tạo ấn tượng khi chuyển từ trang chiếu này sang trang chiếu khác, em nên sử dụng:
	 A. Animation
	 B. Design Ideas
	 C. Transition
	 D. Layout


Câu 25. Nếu muốn bài trình chiếu có phong cách chuyên nghiệp, em nên:
   A. Chèn nhiều hình ảnh minh họa
   B. Viết nội dung thật nhiều trên mỗi trang chiếu
   C. Chọn bản mẫu phù hợp với nội dung bài thuyết trình
   D. Dùng càng nhiều hiệu ứng càng tốt
Câu 26. Nếu em muốn đầu trang và chân trang khác nhau giữa các trang chẵn và lẻ, em cần chọn tùy chọn nào?
	 A. Link to Previous
	 B. Remove Header and Footer

	 C. Different First Page
	 D. Different Odd & Even Pages


Câu 27. Thuật toán là gì?
   A. Một đoạn văn bản trình bày nội dung bài học
   B. Một trò chơi trên máy tính
   C. Một dãy các thao tác được sắp xếp theo trình tự để giải quyết một bài toán
   D. Một phần mềm dùng để lập trình
Câu 28. Lệnh nào dùng để chèn đầu trang trong Word?
	 A. Insert → Header
	 B. Insert → Page Number

	 C. Design → Header
	 D. Layout → Header


Câu 29. Em đã chọn một bản mẫu nhưng muốn tùy chỉnh màu sắc, em nên làm gì?
	 A. Chọn thẻ Design → Variants
	 B. Chọn thẻ Insert → Colors

	 C. Chọn File → Save
	 D. Không thể chỉnh sửa màu mẫu


Câu 30. Khi tạo bài trình chiếu mới, muốn chọn bản mẫu có sẵn, em cần chọn mục nào?
	 A. Blank Presentation
	 B. New → Templates

	 C. Insert → Picture
	 D. File → Save


Câu 31. Lỗi logic trong chương trình có thể gây ra vấn đề gì?
   A. Chương trình không chạy được
   B. Chương trình chạy nhanh hơn
   C. Chương trình chạy nhưng không cho kết quả đúng
   D. Chương trình không thể lưu dữ liệu
Câu 32. Bản mẫu có thể áp dụng được cho:
   A. Một trang chiếu duy nhất
   B. Tất cả các trang chiếu trong bài trình chiếu
   C. Một nhóm hình ảnh
   D. Chỉ phần kết luận
Câu 33. Khi nào nên sử dụng hiệu ứng hoạt hình cho văn bản trên trang chiếu?
   A. Khi không có gì để trình bày
   B. Khi muốn tiết kiệm thời gian thiết kế
   C. Khi muốn văn bản xuất hiện một cách sinh động, thu hút người xem
   D. Khi muốn làm trang chiếu có màu sắc hơn
Câu 34. Em đã chọn một bản mẫu nhưng muốn đổi sang mẫu khác, em nên làm gì?
   A. Không thể thay đổi sau khi đã chọn mẫu
   B. Tạo bài mới từ đầu
   C. Vào thẻ Design → chọn lại mẫu khác
   D. Chèn mẫu bằng cách vẽ thủ công
Câu 35. Một bản mẫu thường giúp định dạng sẵn những gì?
	 A. Dung lượng hình ảnh
	 B. Kích thước tệp tin

	 C. Bố cục, màu sắc và kiểu chữ
	 D. Nội dung bài học


Câu 36. Khi em chọn “Different First Page”, điều gì xảy ra?
   A. Trang đầu tiên có đầu trang/chân trang khác với các trang còn lại
   B. Trang đầu tiên bị xóa toàn bộ nội dung
   C. Tất cả các trang đều không có đầu trang
   D. Chỉ trang đầu tiên có đầu trang
Câu 37. Câu lệnh hình bên thể hiện cấu trúc điều khiển nào?
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	 A. Cấu trúc rẽ nhánh dạng thiếu
	 B. Cấu trúc tuần tự

	 C. Cấu trúc lặp
	 D. Cấu trúc rẽ nhánh dạng đủ


Câu 38. Muốn xóa đầu trang đã tạo, em cần làm gì?
   A. Vào tab Insert, chọn Delete Header
   B. Vào tab Layout, chọn Clear All
   C. Nhấp đúp vào đầu trang, sau đó chọn Remove Header
   D. Dùng phím Delete trong văn bản chính
Câu 39. Điểm khác biệt giữa thuật toán và chương trình là gì?
   A. Thuật toán là ý tưởng giải bài toán, còn chương trình là cách máy tính thực hiện ý tưởng đó
   B. Thuật toán dùng để vẽ, chương trình để chơi game
   C. Thuật toán dùng để trang trí, chương trình để tính toán
   D. Cả hai đều giống nhau hoàn toàn
Câu 40. Mục đích của việc sử dụng bản mẫu là gì?
   A. Giúp chèn thêm nhiều hình ảnh
   B. Giúp tiết kiệm thời gian thiết kế và trình bày nhất quán
   C. Giúp tạo hiệu ứng âm thanh cho bài trình chiếu
   D. Giúp văn bản hiển thị to hơn
Câu 41. Khi tạo đầu trang hoặc chân trang, em có thể chèn loại nội dung nào sau đây?
	 A. Số trang
	 B. Tất cả các đáp án trên

	 C. Hình ảnh
	 D. Văn bản


Câu 42. Em muốn số trang hiển thị ở cuối mỗi trang, em nên thực hiện thao tác nào?
	 A. Insert → Header → Page Number
	 B. Design → Footer → Page Number

	 C. Layout → Page Setup → Page Number
	 D. Insert → Footer → Page Number


Câu 43. Bản mẫu có thể giúp ích như thế nào khi tạo bài trình chiếu theo nhóm?
   A. Tự động tạo nội dung
   B. Giúp mọi người sử dụng màu nền giống nhau
   C. Chỉnh sửa được lỗi chính tả
   D. Thay thế người thuyết trình
Câu 44. Để sử dụng bản mẫu có sẵn trong PowerPoint, em vào thẻ nào?
	 A. View
	 B. Insert
	 C. Home
	 D. Design


Câu 45. Khi em chèn số trang vào chân trang, số trang sẽ hiển thị như thế nào?
	 A. Chỉ ở trang cuối
	 B. Chỉ ở trang đầu

	 C. Ở những trang lẻ
	 D. Ở tất cả các trang


Câu 46. Đoạn chương trình dưới đây không chứa cấu trúc điều khiển nào?
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	 A. Cấu trúc tuần tự
	 B. Cấu trúc lặp

	 C. Không chứa cấu trúc nào
	 D. Cấu trúc rẽ nhánh


Câu 47. Để thay đổi màu nền cho trang chiếu, em vào thẻ nào trên thanh công cụ?
	 A. Home
	 B. Insert
	 C. Design
	 D. View


Câu 48. Vì sao nên sử dụng bản mẫu khi bắt đầu tạo bài trình chiếu?
   A. Để có nhiều trang chiếu hơn
   B. Để dễ chèn ảnh hơn
   C. Để có hiệu ứng âm thanh hay hơn
   D. Để tiết kiệm thời gian và đảm bảo sự đồng bộ về hình thức trình bày
Câu 49. Nếu muốn tất cả các trang chiếu có chung một kiểu định dạng, em nên dùng công cụ nào?
	 A. Slide Sorter
	 B. Slide Master
	 C. Slide Show
	 D. Format Background


Câu 50. Trong chế độ chỉnh sửa đầu trang, chân trang, thẻ công cụ nào sẽ hiển thị?
	 A. Format
	 B. Review
	 C. Layout
	 D. Design


Câu 51. Trong Word, "đầu trang" là phần văn bản được hiển thị ở đâu?
	 A. Ở cuối mỗi trang
	 B. Ở giữa văn bản

	 C. Ở lề trái của văn bản
	 D. Ở đầu mỗi trang


Câu 52. Biểu thức trong lập trình thường được dùng để làm gì?
	 A. Để tính toán và trả về một giá trị
	 B. Để khai báo biến mới

	 C. Để dừng chương trình
	 D. Để lưu trữ giá trị vào bộ nhớ


Câu 53. Nếu bài trình chiếu dùng bản mẫu có thiết kế phù hợp, người xem sẽ:
   A. Theo dõi nội dung dễ dàng và cảm thấy chuyên nghiệp
   B. Dễ bị phân tâm
   C. Không cần đọc nội dung
   D. Khó hiểu nội dung
Câu 54. Nếu em chỉnh sửa nội dung trong đầu trang của một trang, nội dung đó sẽ ảnh hưởng đến:
   A. Chỉ các trang lẻ
   B. Không ảnh hưởng gì
   C. Tất cả các trang nếu chưa bỏ chọn “Link to Previous”
   D. Chỉ trang hiện tại
Câu 55. Tại sao nên chọn màu nền và màu chữ tương phản nhau trong trang chiếu?
   A. Để tiết kiệm thời gian thiết kế
   B. Để tiết kiệm mực in
   C. Để giúp người xem dễ đọc nội dung hơn
   D. Để làm đẹp hơn
Câu 56. Chân trang là phần nào của văn bản?
	 A. Phần ở cuối mỗi trang
	 B. Phần ở bên trái mỗi trang

	 C. Phần ở đầu mỗi trang
	 D. Phần ở giữa văn bản


II. TỰ LUẬN
Câu 1: Em hãy ghép các khối lệnh a, b, c, d vào các vị trí tương ứng 1, 2, 3, 4? Cho biết chương trình trên thực hiện công việc gì?
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Câu 2: Em hãy sắp xếp các bước để chèn vào trang chiếu đường dẫn đến một video sao cho đúng:
a) Chọn Insert/ Links/ Link.
b) Chọn trang chiếu muốn chèn vào đường dẫn đến một video
c) Trong cửa số  Insert Hyperlink,  chọn đường dẫn đến tệp video. Nháy chuột chọn OK.
d)  Chọn một đối tượng trong trang chiếu để đặt liên kết.
Câu 3: Em hãy sắp xếp các bước để đánh số trang trong PowerPoint sao cho đúng:
a. Vào thẻ Insert (Chèn) và chọn Header & Footer (Đầu trang & Chân trang).
b. Tích chọn vào ô Slide number (Số trang chiếu) trong hộp thoại.
c. Nhấn nút Apply to All (Áp dụng cho tất cả) để đánh số cho toàn bộ các trang chiếu.
d. Mở bài trình chiếu cần đánh số trang.
Câu 4:Hình dưới đây là các bước thực hiện một chương trình hoàn chỉnh.
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a. Hãy sắp xếp lại các bước theo đúng trình tự để được chương trình Scratch hoàn chỉnh? 
b. Mô tả lại thuật toán (Bằng sơ đồ khối hoặc ngôn ngữ tự nhiên) 
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